Wednesday, February 1, 2017

AMSOIL Updating Web Security to Increase Payment and Data Protection

We take the protection of our customers’ data very seriously. To comply with security requirements set forth by the members of the Payment Card Industry (PCI), we have been disabling access to secure content via Secure Socket Layer (SSL) 3.0.

Most users will not notice any changes; however, visitors to www.amsoil.com and our affiliate websites whose browsers will no longer be supported and those whose browsers will require additional configuration will notice a popup window warning them of the upcoming change in security. Connecting to any secure area of any AMSOIL, ALTRUM or AGGRAND website, including the account zones, storefront checkout and the Dealer Zone, will require a Transport Layer Security (TLS)-compatible Internet browser. Users with outdated browsers will not be able to create new accounts, log in to amsoil.com or complete purchases.

For more information about the security update or to check your web browser for compatibility, please visit www.amsoil.com/securityupdate2015.aspx.